PDA

View Full Version : Mettler Toledo PS90 Scale



velo
09-30-2011, 08:38 AM
We have an interesting problem with this scale and both Shiprush for FedEx and Shiprush for Stamps.com. (version 9.5.0.46730)

When the scale is set to kg mode (on it's display) shiprush will read the correct weight in lb, but when it is set to lb mode shiprush will read the lb weight with one decimal off.

For instance 4.6lb object on the scale reads as 0.46lb, a 30 lb object 3.0 etc...

This happens for both the initial loading of the weight when you open up an order or blank form, and when you manually click the scale button inside.

I'm guessing that the reasons kg works is because shiprush may divert it to some kind of conversion function that works properly where otherwise this error is occurring.

The first thing I suspected was some setting in shiprush but I can't find it. Unfortunately we installed the latest version and the scale at the same time so I can' tell what's new.


It gets worse, our old scale(ps60) which worked fine will not work with shiprush anymore, shiprush says 'scale not found on this port', and the new scale will not zero without being unplugged.

They are both USB.

SYSOPS
09-30-2011, 09:15 AM
In ShipRush Settings do have it set to All Supported USB Scales or the specific Mettler Scale in the list?

SYSOPS

velo
09-30-2011, 09:36 AM
I've tried it both ways, the all usb scales doesn't report anything. It only ever responds to the "scale name (usb)" which it seems to detect.

SYSOPL
09-30-2011, 02:46 PM
Hrm - we tested out here with a Mettler Toledo PS60 connected via USB and were unable to reproduce. ShipRush read the proper weight from the scale with both the 'all usb connected scales' option and the for the Mettler Toledo (USB).

Are you sure you're not selecting the plain Mettler Toledo PS60 option ? This is a legacy option that was intended for use with COM ports (this is no longer supported in ShipRush).

velo
10-02-2011, 10:19 AM
Yes I'm sure we tried the USB option because that's the only one that produces result. I understand that if you can't reproduce it you don't have much chance of fixing it, I was just hoping something might come to mind.

SYSOPS
10-03-2011, 05:49 AM
Do you have any other application talking to the scale, like another application from the carrier themselves?

SYSOPS

velo
10-03-2011, 10:10 AM
I installed the stamps.com client but I didn't setup the scale with it. We may at some point want to add fedex shipper, but again not yet.