View Full Version : Unable to Connect to Server: Port 1123

07-15-2005, 08:18 AM
Same Noggintops machine I thought we had fixed. Last night everything was OK after reloading Shiprush - did a shipment, end of day, everything fine. Shut machine down overnight. This morning shiprush won't connect to localhost:1123. Posts appear like this is a firewall related problem, but when I disable NIS2005 it still won't work. I tried to create a firewall rule for this port -- it should be a local port, not remote, right? With protocol of TCP and UDP, incoming and outgoing. any computer, any adapter? Help please!

07-15-2005, 08:25 AM
Please try the following. Also make sure that the services described in the kbase article are running:

To make an ADO connection:

When ShipRush fails to connect, will have the option of changing the servername or select Connect to ShipRush via ADO. Select ADO and click Build ADO connection string

Provider Tab
Microsoft OLE DB Provider for SQL Server

Connection Tab
1. servername\SHIPRUSH3 (example...MYSERVER\SHIPRUSH3)
2. Use specific username and password
- username: sa
- password: ***ask us to email it to you***
- Click allow saving password
3. Select the database on the server
- Click the dropdown and select ShipRush -v3

Test connection

If all is good, ShipRush should now connect.


07-15-2005, 08:49 AM
OK, I got connected OK, and can process a shipment. I decided to exit the software and restart it to make sure it was OK. When I exit it gets an unknown software exception (0x0eedfade) occurred in the application at location 0x7c81eb33. I could connect and restart again, but the shipment/end of day I had processed last night do not show up in my database. I will reboot while I wait for your thoughts...

07-15-2005, 08:58 AM
The Fade error is a by-product of switching to ADO. Development is aware of this. Benign issue since it does not impact the product function.

When you stated that you couldn't see your shipment/EOD, did you set the date range back to at least yesterday?


07-15-2005, 09:06 AM
Oh, duh. I guess I am getting too frustrated to think clearly. OK, yes now I can see my yesterday shipments, and OK, I can ignore the FADE error. Have a good weekend anyhow, and hope you don't have to hear from me for a while again!!!!!

07-15-2005, 09:42 AM
Back so soon. I tried to do end of day and it said my shiprush server wasn't running. I went to services, and it wasn't, so I started it. It started OK. I tried end of day again, and got a 40060 Get Status connection error, very similar to the error I started with before I reinstalled the whole shot yesterday.

In services it shows it should start automatically, but I rebooted and started shiprush, and I looked in running services, and again it isn't running. How can I correct this?

07-15-2005, 10:40 AM
Service not starting:
Could be due to a slow PC...does the service start when you manually start it?

Have you disabled sNorton before processing your End of Day?


07-15-2005, 10:52 AM
When is shiprushserver.exe supposed to start? At bootup, or when shiprush starts?

07-15-2005, 10:59 AM
That should be at boot up, it is the Z-Firm ShipRush v3 service.