View Full Version : Scale data not being pulled

08-05-2005, 09:04 AM
Program is not getting data from the scale for FedEx shipments.
I am using a demo ShipRush with Quickbooks Pro 2005 in hybrid mode.
When I try and configure in the shipment settings-scales area only
get a blank drop down box and upon testing the scale, I receive an error
referring to "plug-in not loaded".
Tried re-downloading the demo but that did not make a difference.
Thank you.

08-05-2005, 09:20 AM
Browse out to program files\z-firm llc\shiprush v4
Do you have a scales folder?
Is there anything in that folder?

If not, please let me know. I will email you those files.


08-05-2005, 09:41 AM
Thanks for the response.
I have the scales folder. Below are the contents.


08-05-2005, 09:58 AM
I would suggest uninstall again, and this time rename the following folders:
program files\z-firm llc\shiprush v4
documents and settings\username\application data\z-firm llc

Reboot and run the install again. Something is not correct in the setup so it doesn't know where to get the scale configuration files from.


08-05-2005, 11:04 AM
Thank you for the help.
I uninstalled and renamed the folders and got the same results.
Are the install logs of use in troubleshooting?

08-05-2005, 11:11 AM
No they aren't.

Why kind of scale are you using? What Operating System?


08-05-2005, 11:25 AM
Thank you.
I am using Win2000 and a Mettler Toledo PS60.

08-05-2005, 11:43 AM
USB or COM port scale?


08-05-2005, 11:48 AM
It is a COM port scale

08-05-2005, 12:26 PM
Please search for the following file: shiprushclient4.ini

Locate the following line:
What is the value of that line?

Is that the same location where the dll files are stored on your PC?


08-05-2005, 02:31 PM
Thanks for the help.
I could not find that file.
I am using a demo. Could that be why?

08-05-2005, 02:45 PM
No, the file will exist.

Browse out to documents and settings\username\application data\z-firm llc\shiprush v4

If you cannot see the file, you will need to go into Tools | Folder Options | View | Enable View Hidden files and folders.

Now you should be able to view the folder, and the file.


08-08-2005, 07:18 AM
Thanks for the help.
I found the files in the below location.

C:\Documents and Settings\Alex\Application Data\Z-Firm LLC\ShipRush v4

There are dll files stored in another location below.
Are these the dll files that you are referring to ?

C:\Program Files\Z-Firm LLC\ShipRush v4\SCALES

Thanks again !
P.S. Now what should I do ? :o

08-08-2005, 07:28 AM
OK...the scaleplugindir should point to C:\Program Files\Z-Firm LLC\ShipRush v4\SCALES

Change that value and save the ini file.

Now do you get a scale listing in the settings?


08-08-2005, 07:48 AM
I appreciate the great support.

You mean I should change the entry:

So that it becomes:


Thank you.

08-08-2005, 07:50 AM
Yes...that is correct.


08-08-2005, 08:53 AM
Excellent !!!
I see the drop down now.
When I select the scale and try and test it. I receive a scale not found error.

08-08-2005, 08:59 AM
Make sure that:

It is the right COM port
No other software is talking to the scale (other shipping software)

If that does not help, switch to a different COM port. Does that work?


08-08-2005, 09:24 AM
I tried all of the other ports.
I presume the setting is the default one of

Baud 9600
Data bits 7
Stop bits 2
Parity odd

The error message I get when I test the scale is
"unable to test Mettler toledo (Zffairbanksplugin.dll) scale not found,please correct the settings"

Should it be the Zffairbanksplugin.dll or something like Mettletoledoplugin.dll ?

08-08-2005, 09:32 AM
No that is the correctly file.

The setting should be what SR selects when you choose your scale from the list (changes depending on the scale).


08-08-2005, 12:15 PM
I have identified the port settings for com 1
baud 9600
data bits 8
stop bits 1
parity none

These are what I have now and it still does not work.
Are there any log files that would identify the errors ?

08-08-2005, 12:42 PM
Unfortunately no, since it is trying to communicate to that port\scale, and it cannot.

Those settings you gave may be the generic for a COM port, but the settings will change for the specific scale selected (Mettler will have different settings).

If you have ShipRush installed on a seperate computer, you could try the scale on a different pc with ShipRush and see if that communicates.


08-08-2005, 03:13 PM
Thank you for your help.
Is it maybe that I am running a demo version?

08-09-2005, 05:36 AM
The software functions the same as a fully licensed installation, just that it will stop working after x # of days. Nothing to do with it being in demo mode.


08-12-2005, 04:40 PM
I went to the fedex site looking for configuration information for the scale.
Tried to redownload to see if the problem was my download.
Now my demo is a peachtree demo not quickbooks.
Any suggestions?

08-15-2005, 05:21 AM
If you applied the license that you found at FedEx (they have a license available for Peachtree owners), you will no longer be able to run the demo with QuickBooks.

If you wish to continue the demo, please contact our Customer Service Group at 206.812.7874 for additional assistance. They may be able to provide you with an extended demo license.

Thank you,

08-15-2005, 02:45 PM
Thank you,
Your customer service department issued me a new license.
Is there a way for me to send a logfile that might show an error in
my setup ?

08-16-2005, 06:12 AM
For the scale? No.

There isn't a log. We are trying to communicate with the scale. If it fails, that means for some reason it is unable to talk to the COM port.

A true test, to make sure SR and the scale can talk, would be to install on a different PC. Does SR communicate on that PC with the scale?


08-16-2005, 06:54 AM
The scale works when I use the FedEx Shipmanager alone.

Below is the system information when I look at the com port:

System Information report written at: 08/16/2005 08:45:05 AM

Item Value
Name COM1
Status OK
PNP Device ID ACPI\PNP0501\0
Maximum Input Buffer Size Not Available
Maximum Output Buffer Size Not Available
Settable Baud Rate Not Available
Settable Data Bits Not Available
Settable Flow Control Not Available
Settable Parity Not Available
Settable Parity Check Not Available
Settable Stop Bits Not Available
Settable RLSD Not Available
Supports RLSD Not Available
Supports 16 Bit Mode Not Available
Supports Special Characters Not Available
Baud Rate 9600
Bits/Byte 8
Stop Bits 1
Parity None
Busy -1
Abort Read/Write on Error Not Available
Binary Mode Enabled Not Available
Continue XMit on XOff Not Available
CTS Outflow Control Not Available
Discard NULL Bytes Not Available
DSR Outflow Control Not Available
DSR Sensitivity Not Available
DTR Flow Control Type Not Available
EOF Character Not Available
Error Replace Character Not Available
Error Replacement Enabled Not Available
Event Character Not Available
Parity Check Enabled -1
RTS Flow Control Type Not Available
XOff Character 19
XOffXMit Threshold 512
XOn Character 17
XOnXMit Threshold 2048
XOnXOff InFlow Control Not Available
XOnXOff OutFlow Control Not Available
IRQ Number 4
I/O Port 0x03F8-0x03FF
Driver c:\winnt\system32\drivers\serial.sys (62736, 5.00.2195.6655)

Can you see any red flags?

08-16-2005, 07:07 AM
No we do not.