PDA

View Full Version : Trouble after moving database



Doro
03-12-2013, 07:46 AM
I have tried to move the database from the server computer to a newer computer using the DBManager. Now that I have moved it and changed the paths on "Old Server" "New Server" and another "Workstation" the New Server and Workstation work fine, but the old server keeps popping up a long error message that includes various "cannot locate databaseid" for multiple things. In addition, when i go onto the DBManager on the workstation, under DB Maintenance, the DB path seems to reset to the Old Server.

Doro
03-12-2013, 08:05 AM
Also, going through the Order Manager on the New Server and Workstation says that they are pointing to the right folder.

SYSOPS
03-12-2013, 09:22 AM
but the old server keeps popping up a long error message that includes various "cannot locate databaseid" for multiple things. In addition, when i go onto the DBManager on the workstation, under DB Maintenance, the DB path seems to reset to the Old Server.
Part 1:
The old server might still have the service present, which wouldn't be needed if the database was moved from that environment. To check, go into services in Windows (you can type in services.msc in a run or search window). Scroll to the bottom of the list and see if there's a Z-Firm ShipRush v9 service. If you have one present, stop it, then disable it (no longer needed).

Part 2:
Verify the paths for the databases on all the machines. Those paths reside in these files:

ShipRush database:
C:\Users\Public\Documents\Z-Firm LLC\ShipRush\ShipRushConnectionSettings.ini

OrderManager database:
C:\Users\Public\Documents\Z-Firm LLC\OrderManager\OrderManagerSettings.ini

Check the DBISAM Path value in each. Once we know that's set correctly on each machine, they should all be able to connect without error

Part 3:
As far as the DBManager pointing to the wrong location, either one of the above is incorrect, or there's an "old" entry in an ini about the service. This is a benign issue, and shouldn't be impacting the function of ShipRush on the network. Typically you'd only run the DBManager on the PC where the db actually resides.

SYSOPS

Doro
03-12-2013, 09:40 AM
The "Old Server" computer doesn't have those .ini files but i can find them on the other two computers.

SYSOPS
03-12-2013, 10:23 AM
They might be in a different location, based on the operating system. Try c:\documents and settings\all users\documents\z-firm llc\ShipRush and OrderManager

SYSOPS

Doro
03-12-2013, 10:41 AM
The "Old Server" is using Windows 7 and I could not find the ini files. The Workstation is using Windows 7 as well, it works fine and i have found the files in the place recommended on the other post. The New Server is Windows 8 and is working fine.

SYSOPS
03-12-2013, 11:17 AM
On the "old server", you do have C:\Users\Public\Documents? We don't store the config in a different location in Windows 7. Do a search for one of the configuration files, ShipRushConnectionSettings.ini, on the old server. If ShipRush was installed on that machine, this file exists.

SYSOPS

Doro
03-12-2013, 11:47 AM
Ok, sorry doing a search helped me find it. It seems to have the right path:
<DBISAMPath>\\bby511\users\public\documents\z-firm llc\ordermanager\database\backup</DBISAMPath>
BBY511 is the name of the "New Server" and that matches what the other two computers' files have.

Also new, trying to run shiprush pops up the 2-3 dozen "cannot find databaseID" for various things. Trying to select "find by pc name" instead of directly to the file pops up the error message "DBISAM Engine Eror # 11280 A connection to the database server at 'BBY511' cannot be established."

SYSOPS
03-12-2013, 11:53 AM
Verify that path, as it looks like it might be slightly incorrect. At the end you have database\backup. Typically, the path ends at just database. Could be the reason you're getting 2-3 dozen errors about files missing.

Stick with connecting to database by location rather than PC name as this point.

SYSOPS

Doro
03-12-2013, 12:01 PM
Assuming that to fix that, i just need to delete the "backup" bit, still no change

SYSOPS
03-12-2013, 12:08 PM
Can you verify the path from the working workstation, and post that path here, compared with the path from the old server, where it isn't working?

Also, please keep in mind that the the paths for the OrderManager settings should end in ordermanager\database and the ShipRush settings should end in shiprush\database. If those are mixed up, there could also be issues.

Thank you,
SYSOPS

Doro
03-12-2013, 12:14 PM
Ok, now I am confused. What should each one be pointing to?
On the New server and Workstation that are working:
Going through the order manager, Clicking settings - general - database, "connect directly to database" is selected, "\\BBY511\Users\Public\Documents\Z-Firm LLC\OrderManager\Database"

Order manager, shipping settings, advanced, connection settings, Shiprush server connection, connect via network share "\\bby511\users\public\documents\z-firm llc\ordermanager\database\backup"

Trying to select "database" under "Shiprush" in shipping settings pops up the same "cannot find database id" message like the old server does. I'm so twisted around after working on this so long, i am entirely twisted around honestly.

Doro
03-12-2013, 12:17 PM
Sorry I posted the response to this while you were typing this up apparently. Yes that seems to be the part of the problem then.

SYSOPS
03-12-2013, 12:20 PM
If you wish, give our customer service group a call at 206.812.7874 and we can get you squared up and working from the old server machine.

SYSOPS