View Full Version : Problems after upgrade three screen shots

07-01-2004, 03:29 PM
Performed upgrade as instructed by Tech via phone call. Now we are receiving the following errors, see screen shots. Screenshot 1 happens when we try to run end of day process from system tray. Screenshot 2 happens when we try to view the end of day information from the system tray. Screenshot 3 occurs after you click ok in screenshot 2 and will not go away. You have to end the app from taskmanager. Please help this system is critical for us.

07-02-2004, 06:11 AM
Morning Sam,
Are you with Applied Media?

If you could enlighten me:
When did you call in for tech support?
What exactly did you perform as far as upgrade (from what to what)?

The reason why I ask is that those errors would indicate a serious issue with the database. Seeing as how you posted in the Basic forum, there shouldn't be any database since this data goes directly to UPS. If you're trying to do an End of Day, that means you should have ShipRush UPS v3 Pro, and have posted in the wrong forum.

Please provide more information so we can understand the issue more clearly.
Thank you,

07-02-2004, 06:28 AM
I am with applied media. i spoke to a lindsey (?) yesterday who indicated that we need to upgrade since we were using v. and the current version is v. We do use pro, so i appologize for posting in the wrong forum. We are supposed to be a beta partner and we need some assistance getting this repaired ASAP.

07-02-2004, 06:32 AM
Morning Sam,
Verify that the ShipRush "Server" installation has also been updated to build 281. Sounds as though the update was not applied to the server installation, or did not apply itself correctly to that machine. That is why there are database errors.

Make sure everyone is out of ShipRush, go to the ShipRush Server PC, and run the install again on that machine and choose Update ShipRush. At that time, launch ShipRush on that machine and go into View Shipments | Server Messages. You should see notation that the service started, and it should have a version stamp of If that is correct, try to process your End of Day from that machine and see what happens.

If that works, make sure all other workstations using ShipRush are updated to the same build.


07-02-2004, 06:36 AM
that sounds good in theory, however, All instances of Shiprush were shutdown and the pcs turned off. I am attempting to get shiprush setup on the PC that will be the server for shiprush. Also when i ran the file that we downloaded from your site, i was not presented with an upgrade option at all. I had expected to see that option as that was in the instructions I got from your Knowledge base. The Program just installed like it was new.

07-02-2004, 06:48 AM
If the PC that you were installing had never had ShipRush installed on it, obviously you won't get a pop up asking to update it, since it was never present prior to install.

Again, I need specifics as to what you're doing, since it sounds as though you're doing more than just updating ShipRush, you're also moving to a new server?

Did you choose the Server Option during installation on the new server PC?
Did the PC prompt you to reboot?
If you go into Services on that PC, do you see the Z-Firm Shipping Server listed and running?


07-02-2004, 07:25 AM
this machine was our shiprush server, it had version installed at the time i attempted to upgrade it. all i did was run the executable to install the upgrade. It did not prompt me for an upgrade even though v. was installed and running on the machine.

07-02-2004, 07:49 AM
Morning Sam,
Then that is a serious issue. If the installer did not "see" a prior version, issues abound, and that may indicate why you're having the database issues after attempting the update.

You may need to uninstall\re-install ShipRush on that PC due to this since the database is more than likely corrupted.

This will mean loss of data for prior shipments (history). That is probably the best plan of attack since there is no way to know how bad the database may be corrupted. You may be able to run the installer again on that machine "over the top" and see if that fixes the errors, but I cannot guarantee that will work at this stage.


07-02-2004, 07:54 AM
I just performed the process all over again. Now I am getting this error and the first error I reported originally.
please help ASAP

Error: Invalid column name 'dtExpectedClose'
SQL: SELECT C.BOLD_ID, C.BOLD_TYPE, C.drStarted, C.dtClosed, C.dtUploaded,C.Status, C.AdvancedSettings, C.ActivityType, C.AccountBookPage, B.READ_ONLY

07-02-2004, 08:03 AM
I have a very important question regarding this database. will unistalling the entire program have ANY effect on our Goldmine Database. is this database only in shiprush? If there is no affect on the Goldmine Database then we are willing to give this a shot. thanks

07-02-2004, 08:11 AM
It's own database, not connected to any data already entered and saved in GoldMine from prior shipments.


07-02-2004, 08:57 AM
I tried to uninstall this product and will not uninstall and i cannot install over it. it only gives me update and uninstall options. it is getting worse not better.

07-02-2004, 11:54 AM
The steps for manual removal (so that you can reinstall) are here: