View Full Version : Help with ShipRush Basic UPS error

01-02-2007, 02:13 PM
I have Shiprush Basic for UPS running on 2 machines. Our offices were closed between Christmas and New Years and upon firing everything up today, our ShipRush is not working. The error on both machines is as follows:
Unable to connect to shiprush server Can't get ID, Error #9217, error reading from table or backup file (etc, etc).

I looked up this error in the files and it seems to be a power outage (which certainly could have happened). I copied the database files and then tried to rename the current file to old database, but it won't let me. It says it's protected. Anyway, I am unable to proceed with the fix. I tried to run the DB Manager utility and perform a database repair but it wouldn't let me. It gave me these two errors when I tried to do that:
DBISAM engine error #11013 access denied to table or back up file UPS settings


DBISAM engine error #9217 error reading from the table or backup file ZFRM_ID.

Please help! Thanks.

01-02-2007, 02:25 PM
Logged into the PC as an Admin?
Have you checked to see in Services that the Z-Firm Shipping Service is stopped prior to trying to rename the folder? The service, if there, will have that folder open.

In regards to the 11013 error:


01-02-2007, 03:25 PM
I am logged in as an administer. Z-Firm is not open or running when I try to rename it.

01-02-2007, 05:02 PM

This sounds a bit hairy. A phone call in to our support team may be the best next step.....