PDA

View Full Version : URGENT Error Message



klm
08-07-2007, 09:14 AM
Uninstalled Norton and installed free version of AVG (not internet one; the regular one). Now SR is not working on at least one remote machine (seems to be fine on Server even though uninstalled Norton and installed AVG as well):

Error message: c:\program files\z-firmllc\shoprushv4\upsrates\upssurcharges.xml is not found

Need to take care of this for others in office before I leave for two days.

Thanks,
Karen

klm
08-07-2007, 11:43 AM
Did you receive my message?

SYSOPR
08-07-2007, 01:53 PM
It sounds like the UPS Rate directory is damaged.

There are a couple of ways this could be fixed:

1) (for all ShipRush Pro versions): On a working PC, copy the contents of the \UPSRates\ directory to a problem PC (the data is the same on all systems)

2) (for ShipRush v4.7 Pro and higher) Find the source zip of rates. This can be found here:
"C:\Program Files\Z-Firm LLC\ShipRush v5\upsprocomponents\"

The file is: ShipRush_UPS_Rates.zip

Unzip this to:
"C:\Program Files\Z-Firm LLC\ShipRush v5\upsrates\"

Recreating all subdirectories

klm
08-13-2007, 07:07 AM
This didn't work. I actually had to copy my SR v5 folder to shared folder and then copy it to remote machine first. It was missing tons of files. Then I did what you instructed for v4.7 and higher (we have 5 point something). The error message is still the same and my guess would be that it is trying to pull from v4 as indicated in the error above which seems inaccurate. Please advise!

SYSOPS
08-13-2007, 07:24 AM
Is this on a workstation? If so, the quickest solution might be to uninstall\reinstall ShipRush. Maybe your anti-virus software is deleting files it shouldn't.

SYSOPS

klm
08-13-2007, 07:42 AM
Yes, it's a workstation. I've actually uninstalled and reinstalled at least three times before posting the error message last Wednesday. None of the others is having this problem.

SYSOPS
08-13-2007, 07:43 AM
Uninstall, and then do the following:
http://www.zfirm.com/knowledge_bases/shiprush/sr5a-302.txt

Should be able to skip step 4 as that only applies to the "server" instance.

SYSOPS

klm
08-13-2007, 02:08 PM
I did everything the txt file said to do and then did what the other txt file that file led me to said to do. It is now giving me an error message during installation:

Server Installation failed. Unable to start. Please check SR.log for details. Error during service startup.

If this helps:

Here are two files that both txt files asked me to delete (one from each)

From the txt file above: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Uninstall\{1CA8AE37-22B5-4A0B-1A9C-32E43B7BE67E}
I had a file almost identical, but the 1A9C was 901A or something very close to our shipper number so wasn't sure if it was supposed to be exact. I did not delete it.

Other file that I did not have even though the other txt file said to delete:

Last file mentioned to delete from Registry keys App Paths/yourapp.exe. Didn't have.

Would this matter?

Please help! This is frustrating!

SYSOPS
08-13-2007, 02:37 PM
Go into Services on the PC
Locate the service called ZFirm Shipping Service
Go into the Properties of the service and set to Disabled

If you cannot change the Property, you will need to go into Services on the workstation as an Admin and set that. See if that gets the setup wizard to go through.

SYSOPS

klm
08-14-2007, 06:18 AM
How do I go into Services on the PC?

SYSOPS
08-14-2007, 06:21 AM
Control Panel | Administrative Tools | Services
or
Start | Run, type in services.msc and hit enter

SYSOPS

klm
08-14-2007, 01:10 PM
I think that did it. I had to create a FedEx label before the UPS label would work, but it worked! If I have any problems, I will let you know. Thank you!