PDA

View Full Version : REGSVR32 QBXMLRP.DLL error



kmagg
03-23-2005, 02:28 PM
I get an error on both 2000 and XP machines every time Shiprush starts that the QBXMLRP.DLL file must be registered and the program will run in non-0QBXML mode. I have registered the file by getting to a command prompt, changing to the QB folder and running REGSVR32 QBXMLRP.DLL. I get a file has been successfully registered message, but still get the error message.

I also notice that the Pro version does not pull the email address from QB even though I have that option checked. I appreciate your help on resolving these issues.

SYSOPS
03-23-2005, 02:40 PM
If the QBXMLRP.dll is giving fits, ShipRush will not pull the email address. That requires the qbXML to be functioning.

So how to resolve the dll file error?
Maybe you need to unregister the file first with a command in the QuickBooks folder:
regsvr32 /u qbxmlrp.dll
Reboot the PC and then go back to that folder from a command prompt and do
regsvr32 qbxmlrp.dll

You may also need to apply the lastest update available for your version of QuickBooks.

SYSOPS

Elric
03-24-2005, 10:24 AM
I am aslo experiencing the same problem.

I have followed the steps that you have outlined and the error is still occuring.

Any further suggestions? Will there be a patch to fix this issue?

SYSOPS
03-24-2005, 10:34 AM
The issue is with a QB file, not a ShipRush file.

The only other suggestion to try and resolve a possible QB issue is to back up your data and re-install QB. Possibly you have a corrupt registry entry or corrupt file.

If you have another installation of QB on another PC, you could try and rename qbxmlrp.dll, take a copy from the other PC, unregister and then reregister.

What build\version of QuickBooks are you using?

SYSOPS

twistedthrottle
03-24-2005, 11:02 AM
We also have the same problem. We're running Windows XP Home on some computers, Windows XP Pro on others. Quickbooks Premier 2002 (latest patch, which was released just a week or two ago). The same problem effects all computers in our office. We've done all the steps you list on this forum for regsvr.

We did not have this problem until we installed the latest "upgrade" of Shiprush v3 that was released this week. Our earlier versions of Shiprush v3 did not have this problem.

Thanks,
-Erik

SYSOPR
03-24-2005, 11:15 AM
Holy Smokes! 3 sites all at once?

Ouch, and sorry for the hassle here.

First, some notes:

Sometimes changing versions of ShipRush will tweak the ShipRush QB related settings, so be sure to go into Settings | Program Settings | CM Settings and check that they are correct.

The off the cuff response on the Z-Firm side is:
That is clearly a QB related error, we have seen it rarely in the past, and reinstalling/repairing QB has always been the solution.

Now if the problem was installing a new ShipRush, then we may have something to chase down on our end. It is also possible that QB slipstreamed an update to you around the same time, and the problem is coming from QB.

(We had a couple of hundred QB users update to the latest ShipRush in the last 2 weeks, but these three posts are the first we have heard of this problem.)

It would be helpful if you could be crystal clear with us here, e.g.


"On Monday ShipRush was great, I was running the version from last September [version # if you know it], Tuesday morning I updated ShipRush, and the first shipment I did got this error [screen shot of error attached--See FAQ on this site for how to attach screen shots to post]"

or


"On Monday ShipRush was great. On Tuesday AM I updated to the latest ShipRush, version XXXX, and shipped Tue and Wed fine. Then on Thursday I started getting this error [screen shot attached]

Get the idea.... this is a bit of a squirrel, since so far Z-Firm cannot see the problem.

Z-Firm will spend some time trying to reproduce the problem. What we need from y'all is:

a) Complete version and build of QB that is running
(E.g. QB Pro, multi user, full build of QB from Help | About)

b) Complete version and build of ShipRush that is running (from Help | About)

THANK YOU for the help here. As we like to say: We can fix what we can see. So far, y'all are the only ones who can see this, so we need your eyes!

twistedthrottle
03-24-2005, 11:32 AM
Shiprush v3.0.0.664
URC file version URC39.OV
Quickbooks Premier 2002, with latest updates installed (Quickbooks has an automatic update feature that grabs all updates the same day they're released; no build numbers are viewable from within Quickbooks). We're in multi-user Quickbooks mode (always have been). The error started showing up immediately when we installed the latest upgrade to Shiprush v3.0.0.664.

Exact error message that pops up when starting Shiprush v3:

Warning

Error accessing Quickbooks in QBXML mode. Please make sure that you are using Quickbooks 2002 Pro or higher and <Quickbooks dir>\QBXMLRP.DLL is registered. In order to register QBXMLRP.DLL type "REGSVR32 QBXML.DLL" in the command line. The operation will continue in non-QBXML mode.


We've done the registry of QBXMLRP.DLL successfully and still had the problem. We then rebooted, tried again, unregistered the DLL, rebooted, tried again, registered the DLL, and rebooted again, and still no change.

Is that everything?

Thanks,
-Erik

SYSOPS
03-24-2005, 12:03 PM
Just an idea:

Get everyone out of QuickBooks
On one PC, log into QB - Single User Mode as ADMIN

Go into Edit | Preferences | Integrated Applications | Company Tab
Delete any references to ShipRush v3 listed
Close the Preferences Window
Try to process a shipment with ShipRush
Do you get a prompt asking to list as an integrated application? If so, agree to it

If that works, process another shipment. Does that prompt you in QB to list as an integrated application? If so, agree.

Now log into QB in multi-user mode as you normally would and see if ShipRush functions correctly.

Please let us know,
SYSOPS

twistedthrottle
03-24-2005, 12:32 PM
Tried it - removed Shiprush UPS from the integrated applications.

Then tried running a shipment. I got the same error, but was able to run the shipment based upon the invoice itself. I then looked in Quickbooks Preferences, and nothing was in there for UPS Shiprush. It looks like Shiprush isn't asking to be made into an integrated application.

SYSOPS
03-24-2005, 12:37 PM
OK...that means it is still something about the qbxml file.

Thank you for the feedback on that test.

SYSOPS

SYSOPR
03-24-2005, 12:49 PM
Quickbooks Premier 2002,

2002 has qbxml or was 2003 the first version with qbxml?

What version of QB are the other folks with that version running?

Do you have ShipRush FedEx ?

Does it throw the same error ?

twistedthrottle
03-24-2005, 01:15 PM
We have Shiprush FedEx as well, which seems to be working just fine.

Our Shiprush v3 UPS is the only one having the errors. Maybe we should downgrade?

Also, on the Shiprush v3 UPS Program Settings >> Notifications page, there's not currently a checkbox to send a notification to the shipment recipient. I thought there was a checkbox there in previous versions of Shiprush. Has the option been removed, or is it a symptom of operating outside XML mode?

SYSOPS
03-24-2005, 01:16 PM
The email not populating is a symptom of the qbxml issue.

SYSOPS

twistedthrottle
03-24-2005, 01:30 PM
I just tried uninstalling both Shiprush v3 UPS and Quickbooks, then reinstalling (and doing required reboots). Still no luck. Argh.

twistedthrottle
03-24-2005, 01:31 PM
Do you have a good copy of the DLL file I can download and try on my system?

twistedthrottle
03-24-2005, 04:46 PM
No other suggestions?

SYSOPS
03-25-2005, 07:39 AM
We are working on trying to replicate this issue. Hard to provide a solution when we do not know what the true problem is.

Please stand by,
SYSOPS

SYSOPS
03-25-2005, 10:22 AM
Replication has not shown us the issue as of yet.

Couple other questions:

a) antivirus software running? Disable it
b) a virus - have you scanned the PC for a virus?
c) any other add on app that uses qbxml with QuickBooks? If so, close it(them).

Other thing, search the PC in question for QBXMLRP.dll. How many do you find, and where is it located? Could you please provide us with the version information of that file (right click | properties)? File version and Product version.

Thank you,
SYSOPS

SYSOPR
03-28-2005, 04:42 PM
We have a workaround for this problem.

Please post here if you need it. (Also please post your company name in your post if we cannot tell from your forum login id.)

RVPigtails
03-29-2005, 05:13 PM
I am having the same problem.

Quickbooks Pro 2002 v 10.0.4.8
QBXMLRP.DLL v 1.1.4.8
Shiprush v 3.0.0.664

Thanks

John Rentfrow
R.V. Pigtails
jrentfro@kresanet.org

Login ID : RVPigtails

SYSOPS
03-31-2005, 06:02 AM
Morning John,
Didn't see this post until now.

Email has been sent.

SYSOPS

SYSOPR
03-31-2005, 05:59 PM
An update for y'all: We figured out how to reproduce the problem.

The problem is caused by WindowsXP SP2 or hot fixes to Internet Explorer (even without SP2, or on Win2k probably). Microsoft changed a core piece (kind of broke it, actually) of IE.

Now the reason ShipRush FedEx works (and older ShipRush Pro) is because they lack a new internal component of ShipRush. This was added in January. Only ShipRush versions since January that run with a super-hot-fixed IE will show this problem.

Soooooooooo the good news is that it is completely under control.

The bad news is that, as usual, patching has its dangers. ... This is why it tool a long time for Z-Firm to see the problem.... we had to run:
Super patched OS
+ QB 2002
+ Freshest ShipRush

All at once. Any deviance from this combination and.... no problems!

So we are working on a new build (for several reasons, this being just one) that should resolve this ..... until Microsoft breaks the next thing in their next hot fix.