PDA

View Full Version : Problem moving shiprush to server



minorgod
03-25-2005, 02:19 PM
We had shiprush pro v3 (latest version) configured to run on a workstation that was also running a copy of Quickbooks Pro 2005 (multiuser). It was working great until we decided to set up a server to host Quickbooks and Shiprush. I tried to install the server version of Shiprush on the server, but got an error after the system rebooted because there was not a copy of Quickbooks installed on the server and Shiprush was looking for the default contact manger. I realized that this was just an issue with the Shiprush3 client and not the server so I just quit the Shiprush3 client on the server since I only want to run the shiprush server on the new server. I then copied the shiprush database files from the previous server to the new server and rebooted and everything seemed to be working after that. The server is now installed and all our network machines are able to use the shiprush server for everything, but now we are unable to process end of day. We are getting the following error:


Unable to process End of Day request. Acct/mailbox pair not found ('xxxxxx/SYSTEM_M0506320466883406')

Edited for content.

SYSOPS
03-25-2005, 02:35 PM
As discussed on the phone:

To do a system restore you must follow the discussion in the helpfile:
http://www.zfirm.com/Product_Documentation/ShipRush_v3_Pro_Edition/Move_ShipRush_to_a_New_Computer.htm

If you do not do the system restore procedure, information will not be present in the registry about the account when it first commissioned.

Sorry for the hassle on this, but there isn't too much else we can do in that situation.

SYSOPS

minorgod
03-25-2005, 02:42 PM
Problem solved. I copied the registry key from the old server to the new server. The key that needed to be copied was...

[HKEY_LOCAL_MACHINE\SOFTWARE\UPS\UPSlinkHTTP\Client s\ShipRushServer]

Once I did that, I was able to process my end of day. Now I'm getting a strange CMS error, but I think that's becuase I'm trying to upload the same batch of transactions twice. I ran the end of day on the data where I had tried to delete the shipments and it worked fine. Then I restored the database with the undeleted shipments and tried to do the end-of-day again and then I got the following error:


Upload error: upload PLD connection error: Transaction failed - a CMS error has occured [50510]
I'm assuming this is just because I've already uploaded those transactions with a status of "VOID" so it's not letting me upload them again. Does that sound like the problem?

SYSOPS
03-25-2005, 02:59 PM
This may still be an issue of the restore procedure, or the fact that an upload was attempted before the registry was restored (could have caused information conflict).

Did the End of Day actually work and the information printed out, or is this the next error in the process?

SYSOPS

minorgod
03-25-2005, 03:41 PM
End of day actually printed. I think the problem is just that I had already uplaoded the info once after I changed the registry. I had "deleted" today's shipments when I was trying to get it working earlier. Once I changed the registry and got the end-of-day to process, I restored a backup of the database with today's shipments NOT deleted, and ran the end-of-day again. It was then that I got the new error.

SYSOPS
03-25-2005, 04:00 PM
Hard to answer. This whole environment had been through a partial restore, registry entry change, then a restore again.

Can you restore to before you restored with the shipments NOT deleted? There are many parts of the puzzle that must line up with ShipRush and the UPS account.

Otherwise, to make sure we won't be dealing with more issues, a full restore should be done as documented in the helpfile.

SYSOPS

minorgod
03-28-2005, 01:26 PM
Looks like that last error was simply caused by trying to upload the same transactions twice. So, here's the final word. I was able to install the shiprush server and then simply copy the database files without exporting them and importing them. All that was required was copying that registry key. Problem solved!

Thanks for you help.