PDA

View Full Version : Running ShipRush without HTTP port 80



jasonITSpyder
09-27-2011, 02:15 PM
ShipRush (stamps.com) is running in my warehouse, with HTTP port blocked/denied (Cisco ASA firewall). For every now and then (pretty much daily), I would have to go to the warehouse and change the IP's to one that doesn't have HTTP blocked, print out a label and then switch it back to the original IP. Otherwise I would get an ShipRush error connecting to stamps.com

I have tried running a proxy server and have ShipRush connect through the proxy, but that did not resolve the issue.

All HTTPS ports are open though.

In my firewall ACL, I do allow the warehouse computers to connect through the IP address range for Stamps.com though (216.52.0.0 - 216.52.255.255), but that doesn't seem to help either.

Basically I'm looking at these possible solutions. I need your help/advise on them. Feel free to add more.

1) Need all IP addresses used by ShipRush for stamps.com, so I will have them in the "permit" ACL --- (I know this may not be possible, but doesn't hurt by asking)

2) Make ShipRush work on a different port (instead of the HTTP port)

3) ShipRush mods/programmer - Please set up a similar environment and test it out with different proxies, and advise which one works *ALL* the time.

I'd like to point out that we've been having this issue with ShipRush for Endicia too. I'm pretty sure many other businesses are interested in a solution like this too. Who would want their warehouse guys to browse the web all day long?

I'd really like to find out a solution to this issue, so we can keep using ShipRush. Otherwise I may be researching for a different USPS solution for our business. As a matter of fact, we like ShipRush a lot and we are a pretty heavy user of ShipRush (bought approx $250,000 postage last year). I have a screen shot here hope it can accelerate things a little.

http://i780.photobucket.com/albums/yy89/jasonitspyder/endicia.jpg

SYSOPR
09-27-2011, 03:22 PM
We are researching this. We are confident we can get this solved for you.

Stand by.

SYSOPR
09-27-2011, 03:24 PM
ZF Case 29036

SYSOPR
09-27-2011, 03:25 PM
ZF Case 29036

Please allow us until tomorrow to get the story on this.

Thanks!

SYSOPP
09-27-2011, 06:08 PM
We got a response on this:

https://swsim.stamps.com = 216.52.211.66:443
https://customer.stamps.com = 216.52.211.69:443

*.internetpostage.com
*.stamps.com

I am checking to ask if this is everything.

jasonITSpyder
09-28-2011, 09:08 AM
Thanks for all the updates. Pls keep us posted.

SYSOPR
09-28-2011, 09:34 AM
They have confirmed to us that the list posted earlier (and copied below) is complete.

If there are any problems, please let us know.


>>>
https://swsim.stamps.com = 216.52.211.66:443
https://customer.stamps.com = 216.52.211.69:443

*.internetpostage.com
*.stamps.com
<<<

jasonITSpyder
10-03-2011, 02:27 PM
Thanks for the ip addresses. Looking good so far.

jasonITSpyder
10-11-2011, 03:08 PM
Problem coming back again. See attached screenshot below for error message.

What I have so far on the network setting:

1) Allow all connections to stamps.com ip address on port 80. No HTTPS port is blocked

2) Tested connection on the warehouse computers - I can successfully browse stamps.com

The only way to get ShipRush to work again is to: 1) Switch to an IP that doesn't have HTTP port 80 blocked 2) Print out a label 3) Then switch back to the original IP

Here's the screen shot. Desperately need another solution

http://i780.photobucket.com/albums/yy89/jasonitspyder/SHIPRUSH-HTTP1.jpg

http://i780.photobucket.com/albums/yy89/jasonitspyder/SHIPRUSH-HTTP2.jpg

SYSOPR
10-11-2011, 04:01 PM
As you mention, this issue is caused by the ip blocking on the firewall.

Please email into support at shiprush.com. We can get this solved, we believe.