Untitled Document
Page 1 of 6 123 ... LastLast
Results 1 to 10 of 60

Thread: Orders not being marked as Complete and tracking info not saved

  1. #1
    We are using Magento 1.7.0.2. Back in July, the ShipRush system stopped marking our orders as complete. Also, it is not saving the tracking info to our Magento orders.

    I know the My.ShipRush settings are correct as it shows all current and shipped orders online just fine, including the tracking numbers. It is just not getting sent to the Magento admin.

    Also, since we now have tons of orders still marked as processing in Magento since ShipRush did not update them, is there a way to mark them all as complete and bring over the tracking info? Or at least mark them as complete?

    Thanks!
    Jonathan

  2. #2

    Join Date
    Apr 2004
    Posts
    14,412
    SYSOPS is offline
    It would appear that your Magento environment might not be setup properly for the Web Role Resources. Reviewing the logging for your webstore in My.ShipRush, it is failing on the post back portion:
    Unable to communicate with the Magento API. Please review the Magento setup documentation

    I would refer back to the PDF file for setting up the role and resource, available here:
    https://my.shiprush.com/assets/ShipR...EADME_file.zip

    Specifically, the resources for order shipments.

    We do not have a way to easily upload that data since July.

    SYSOPS
    Have Questions? Ask the Z-Firm Knowledge Base: http://www.zfirm.com/support/knowledge_base.asp
    Reply With Quote

  3. #3
    When I go to System, Web Services, I see the below options:


    Then, under the role/resources I do see an option that is not listed on your PDF...should it be checked? It isn't shown at all on your screenshot in your PDF. Maybe this is something in a newer version of Magento?


  4. #4
    Also, all shipments and processing orders that have not been shipped are showing fine at https://my.shiprush.com/shipments.aspx. It is just not posting back to Magento admin.

  5. #5

    Join Date
    Apr 2004
    Posts
    14,412
    SYSOPS is offline
    An option would be to set the Role Resources for ShipRush to all or admin (all options checked), save the role\resource, and see if ShipRush is able to post back to Magento with the tracking info after you process a shipment.

    Also, all shipments and processing orders that have not been shipped are showing fine at https://my.shiprush.com/shipments.aspx. It is just not posting back to Magento admin
    Yes, as the issue is the postback to Magento, only.

    SYSOPS
    Have Questions? Ask the Z-Firm Knowledge Base: http://www.zfirm.com/support/knowledge_base.asp
    Reply With Quote

  6. #6
    Thanks. We will try that. Is it safe to set it to "all"?

  7. #7

    Join Date
    Apr 2004
    Posts
    14,412
    SYSOPS is offline
    As a baseline test, yes.

    If that does work, then you can look at turning off options that have nothing to do with Order Details, or Shipping Details to narrow it back down.

    SYSOPS
    Have Questions? Ask the Z-Firm Knowledge Base: http://www.zfirm.com/support/knowledge_base.asp
    Reply With Quote

  8. #8
    I just tested it and it did not work, unless it takes some time for it to update. I shipped a package about 3 minutes ago and it still says "processing" and no tracking number is showing in the Magento admin.

  9. #9

    Join Date
    Apr 2004
    Posts
    14,412
    SYSOPS is offline
    That is an odd issue indeed.

    The suggestion would be to note the password that you have for the Web User, and then to delete the user and resource, and create them "new" following the PDF file for Magento. Something has gone wrong with the current setup and this is the next thing to try.

    SYSOPS
    Have Questions? Ask the Z-Firm Knowledge Base: http://www.zfirm.com/support/knowledge_base.asp
    Reply With Quote

  10. #10
    Thanks. Would I delete the user and create a new one user the "SOAP/XML-RPC - Users" tab under Web Services??

    As mentioned above, mine does not follow your PDF. Maybe because I have version 1.7.0.2??

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •