Untitled Document
Results 1 to 4 of 4

Thread: Labels Do Not Print Correctly for Multi-Piece Shipments

  1. #1
    Zebra label printer goes totally wonky on multi-piece shipments - it will not print all the labels in sequence like it should.

    For example, yesterday on a shipment of 12 packages to one destination address, when we hit F10 to ship and print labels we got labels for packages #1, #2, #4, #5, #7, #10... and then it stopped.

    All 12 shipments were properly created by Fedex (12 tracking numbers in the SR history grid), so we select one of them in History grid & hit REPRINT, and get another crazy batch with some of the same labels that printed initially and one or two of the ones that did NOT print on the first run. So then we hit REPRINT again, and hope that we'll get more of the ones we need. Sometimes on a large order like this one it requires hitting REPRINT 4 or 5 times to wind up getting all the labels we need, and then we have about THIRTY or so duplicates to trash.

    If a shipment consists of only TWO labels, we always get them both just fine - #1 of 2, and # 2 of 2 - perfect. But if there are THREE labels, we'll get only two of them. Sometimes #1 and #2, sometimes #1 and #3 - but never all three (until we select from History grid & do the REPRINT dance).

    We're on SR v 11.0.8.4014, Windows XP (yeah, I know, but it works fine (except for this printing issue)). Machine has ample RAM (4G I think), ample HD space (couple hundred gig)... I have tried two different printers (Zebra ZP500 Plus and a ZP 505) both local (USB), same thing. I tried several different USB printer cables, no difference.

    When I change settings in ShipRush to make it store the labels as PDF's, all labels are created & stored just fine, but of course we don't want to do that & then print from the PDF's, need to hit F10 & get all the labels in sequence & keep rocking.

    Any thoughts are greatly appreciated!!

  2. #2

    Join Date
    Apr 2004
    Posts
    17,009
    SYSOPS is offline
    I was going to suggest updating ShipRush, but v11.2 may not work very well on XP with the changes to security and SSL. So, let's try and stay on this build from late 2015 for now.

    First Test:
    Pause the Printer in Windows
    Do a test MPS shipment from blank shipment
    3 or 4 packages
    Ship it
    Open the print queue for the printer. How many print jobs do you see queued up? Should be the same number as shipments. Leave the printer paused for the next steps

    If that looks correct

    Second thing to check:
    Settings | Shipping Settings | Printer
    What density is it set to? Should be set to 10

    Third thing to check
    Devices and Printers in Windows
    Your thermal printer | preferences
    What is the density set to there (might be called darkness)? Set it to a value in the middle, like 15

    Unpause the printer. Do you get all the labels?

    SYSOPS
    Have Questions? Ask the ShipRush Knowledge Base: https://shiprush.com/kbase
    Reply With Quote

  3. #3
    UPDATE - Problem Solved!

    After posting a few minutes ago, I then noticed that I still had time to call SR support (forgot Z-Firm is on the west coast!), so I did. Tech agent Angela suggested I purge & rebuild the SR database, which I did, and it SEEMS to have solved the issue - I did a couple dummy multi-piece shipments and they both printed fine! Real test will be live shipments over the next week or so, but I am very hopeful!

    (And thank you for your quick response!)

  4. #4

    Join Date
    Apr 2004
    Posts
    17,009
    SYSOPS is offline
    Good to hear and thank you for the update.

    SYSOPS
    Have Questions? Ask the ShipRush Knowledge Base: https://shiprush.com/kbase
    Reply With Quote

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •