Untitled Document
Results 1 to 9 of 9

Thread: Weird Issue with CT or Court in Addresses

  1. #1
    We're experiencing a weird issue wherein address are failing to ship in FedEx ShipRush when they contain "COURT" or "CT" in the Address line. The error looks like this:

    Name:  Untitled-1.png
Views: 79
Size:  16.1 KB

    Initially, I thought this was an issue on FedEx's end, but these addresses appear to go fine in FedEx Ship Manager software.

    Additionally, when I independently run these addresses through FedEx's API, they appear to come up clean with "Resolved" set to "true." I have an example of the xml results of one of the API address validations that can share via PM, but I don't wish to post a customer's address in a public forum.

    Thanks,

    Tim Levine

  2. #2

    Join Date
    Apr 2004
    Posts
    16,808
    SYSOPS is online now
    Have you attempted to validate the address at FedEx.com itself? We use the same address validation tool as found there. 99% of the time, we see the same behavior there. You can share the address via email and send to support at shiprush dot com. If it fails at FedEx.com, it is a FedEx issue.

    SYSOPS
    Have Questions? Ask the ShipRush Knowledge Base: https://shiprush.com/kbase
    Reply With Quote

  3. #3
    I'm unaware of where an address can be validated on FedEx's website. Again, the address DID validate when going directly through their API.

  4. #4
    This gets weirder and weirder. I tried entering and validating the address in the online version of FedEx Ship Manager at FedEx.com. If I try validate using the +4 zip code it validates. If I try validate using just the 5 digit zip code, it fails.

    When we are sending data to ShipRush from SQL, we do a left 5 on zip code to get the 5 digit zip, which presumably was causing the failure described above. However, if I change our Contact Info SQL SELECT Statement to allow the full zip, the hyphen inexplicably gets stripped out, causing it to fail unless I manually add it back in through the GUI.

    Is there a reason that ShipRush is removing hyphens from the ZIP field on SQL imports? Can this be corrected?

  5. #5

    Join Date
    Apr 2004
    Posts
    16,808
    SYSOPS is online now
    There may be a cleanup function being triggered on import. The real issue is why is FedEx failing a valid address without the +4 associated to it? You can email in a couple examples of failing addresses with the 5 digit zip and we will forward to FedEx. If they fail to work properly at FedEx.com, you can engage with support directly as their system should work with 5 digits for a zipcode. That's what the system is supposed to do.

    SYSOPS
    Have Questions? Ask the ShipRush Knowledge Base: https://shiprush.com/kbase
    Reply With Quote

  6. #6
    I only have 1 example where I've demonstrated this behavior. Who do I need to e-mail to? Scott?

  7. #7

    Join Date
    Apr 2004
    Posts
    16,808
    SYSOPS is online now
    support at shiprush dot com

    Thank you,
    SYSOPS
    Have Questions? Ask the ShipRush Knowledge Base: https://shiprush.com/kbase
    Reply With Quote

  8. #8

    Join Date
    Apr 2004
    Posts
    16,808
    SYSOPS is online now
    We've submitted this address example to the support team at FedEx.com.

    Thank you,
    SYSOPS
    Have Questions? Ask the ShipRush Knowledge Base: https://shiprush.com/kbase
    Reply With Quote

  9. #9

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •