Untitled Document
Results 1 to 5 of 5

Thread: Unknow character

  1. #1
    Hi,

    We use shiprush web service sent the attchment below.
    8341572_Request.txt

    And got the error message.

    <?xml version="1.0"?><error><shipError Value="Unable to convert XML to ShipRush friendly XML: An invalid character was found in text content.

    Line: 1
    CompanyAddress1PO BOX 42213/Address1"/></error>

    Don't know what is the problem.
    We use the same address to other orders, but only had this error
    Last edited by captechnical; 07-28-2020 at 02:23 AM.
    Reply With Quote

  2. #2

    Join Date
    Apr 2004
    Posts
    17,017
    SYSOPS is offline
    I don't see anything invalid in the example request.

    The line 1 you then show is an issue:
    CompanyAddress1PO BOX 42213/Address1"/></error>

    It would appear that there isn't proper XML formatting between the company and address1 elements, and they run-on into each other.

    SYSOPS
    Have Questions? Ask the ShipRush Knowledge Base: https://shiprush.com/kbase
    Reply With Quote

  3. #3
    Hi,

    Here is the successful request xml.

    SuccessRequestXML_0803.txt

    Could you help to check if something different with the error request xml?

    Thank you.

  4. #4

    Join Date
    Apr 2004
    Posts
    17,017
    SYSOPS is offline
    I compared the two requests...and they both look valid. What happens if you submit the failing one again? Same error?

    Thank you,
    SYSOPS
    Have Questions? Ask the ShipRush Knowledge Base: https://shiprush.com/kbase
    Reply With Quote

  5. #5
    Hi,

    The successful request is another order, not same order.
    We've submitted the request several times, which we got an error message, but still fail.

    Thank you

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •