Untitled Document
Results 1 to 6 of 6

Thread: Incorrect delivery confirmation email address

  1. #1
    We are trying to implement the ShipRush version 8 for FedEx using the Browser Integration method. We are sending info for the Notification, Exception and Delivery Addresses. We are sending the user email and an admin email for both the Notification and Exception but are sending only the user email for the Delivery address. When ShipRush pops up the Notification and Exception address are correct but the Delivery address contains the user address twice plus the admin address. Our link is as follows:
    <a onclick="timer=setTimeout('reload()',3000); return true" id="shiplink" href="nntp://ship?Carrier=FEDEX&ShipmentXML=%3c%3fxml+version%3 d%221.0%22%3f%3e%3cRequest%3e%0d%0a%3cShipTransact ion%3e%0d%0a%3cShipment%3e%0d%0a%3cUPSServiceType+ Value+%3d+%22FDXGD92%22%2f%3e%0d%0a%3cHasShipNotif ication%3e1%3c%2fHasShipNotification%3e%0d%0a%3cSh ipNotificationEmail%3etest%40test.com%2c+tracking% 40company.com%3c%2fShipNotificationEmail%3e%0d%0a% 3cHasExceptionNotification%3e1%3c%2fHasExceptionNo tification%3e%0d%0a%3cExceptionNotificationEmail%3 etest%40test.com%2c+tracking%40company.com%3c%2fEx ceptionNotificationEmail%3e%0d%0a%3cHasDeliveryNot ification%3e1%3c%2fHasDeliveryNotification%3e%0d%0 a%3cDeliveryNotificationEmail%3etest%40test.com%3c %2fDeliveryNotificationEmail%3e%0d%0a%3cDeliveryAd dress%3e%0d%0a%3cAddress%3e%0d%0a%3cFirstName+Valu e+%3d+%22test%22%2f%3e%0d%0a%3cCompany+Value+%3d+% 22test%22%2f%3e%0d%0a%3cAddress1+Value+%3d+%221451 +test+Road%22%2f%3e%0d%0a%3cAddress2+Value+%3d+%22 %22%2f%3e%0d%0a%3cCity+Value+%3d+%22test%22%2f%3e% 0d%0a%3cState+Value+%3d+%22MD%22%2f%3e%0d%0a%3cPos talCode+Value+%3d+%2220768%22%2f%3e%0d%0a%3cCountr y+Value+%3d+%22US%22%2f%3e%0d%0a%3cPhone+Value+%3d +%221234567890%22%2f%3e%0d%0a%3c%2fAddress%3e%0d%0 a%3c%2fDeliveryAddress%3e%0d%0a%3cPackage%3e%0d%0a %3cDCISType%3eDCS%3c%2fDCISType%3e%0d%0a%3cPkgHasD eliveryNotification+Value+%3d+%221%22%2f%3e%0d%0a% 3cInsuranceAmount+Value+%3d+%22139.08%22%2f%3e%0d% 0a%3cPackageReference1+Value+%3d+%22Ord%23911%22%2 f%3e%0d%0a%3cPackageReference2+Value+%3d+%22%22%2f %3e%0d%0a%3c%2fPackage%3e%0d%0a%3c%2fShipment%3e%0 d%0a%3c%2fShipTransaction%3e%0d%0a%3c%2fRequest%3e %0d%0a&PostBackURL=http://company.com/postback.aspx?otype=0&oid=911&sid=217&">Ship Order Via FedEx</a>

    Any idea what is causing this?
    Randall
    Stokes Web Development

  2. #2

    Join Date
    Apr 2004
    Location
    Seattle
    Posts
    8,957
    Blog Entries
    1
    SYSOPR is offline
    Couple quick suggestions:

    1) Try a couple of different browsers, to be sure you are not hitting a browser limitation.

    2) Try stripping it down to just feed email addresses, just feed physical address, etc. to focus the investigation.
    -----------------------------------
    The Blog: http://forums.zfirm.com/blog.php

    YouTube channel: http://youtube.com/shiprush

    Thank you for using ShipRush!
    Reply With Quote

  3. #3
    I have stripped the code down to its bare minimum and the problem still exists. I have tested in multiple browsers on multiple computers.

    The link is:
    Code:
    <a href="nntp://ship?Carrier=FEDEX&ShipmentXML=%3c%3fxml+version%3d%221.0%22%3f%3e%3cRequest%3e%0d%0a%3cShipTransaction%3e%0d%0a%3cShipment%3e%0d%0a%3cUPSServiceType+Value+%3d+%22FDXGD92%22%2f%3e%0d%0a%3cHasShipNotification%3e1%3c%2fHasShipNotification%3e%0d%0a%3cShipNotificationEmail%3etest%40test.com%2c+tracking%40company.com%3c%2fShipNotificationEmail%3e%0d%0a%3cHasExceptionNotification%3e1%3c%2fHasExceptionNotification%3e%0d%0a%3cExceptionNotificationEmail%3etest%40test.com%2c+tracking%40company.com%3c%2fExceptionNotificationEmail%3e%0d%0a%3cHasDeliveryNotification%3e1%3c%2fHasDeliveryNotification%3e%0d%0a%3cDeliveryNotificationEmail%3etest%40test.com%3c%2fDeliveryNotificationEmail%3e%0d%0a%3c%2fShipment%3e%0d%0a%3c%2fShipTransaction%3e%0d%0a%3c%2fRequest%3e%0d%0a&PostBackURL=http://www.companyurl.com/postback.aspx?oid=1234">Ship Order Via FedEx</a>
    A more readable version is:
    Code:
    <?xml version="1.0"?>
    <Request>
    <ShipTransaction>
    <Shipment>
    <UPSServiceType Value = "FDXGD92"/>
    <HasShipNotification>1</HasShipNotification>
    <ShipNotificationEmail>test@test.com, tracking@company.com</ShipNotificationEmail>
    <HasExceptionNotification>1</HasExceptionNotification>
    <ExceptionNotificationEmail>test@test.com, tracking@company.com</ExceptionNotificationEmail>
    <HasDeliveryNotification>1</HasDeliveryNotification>
    <DeliveryNotificationEmail>test@test.com</DeliveryNotificationEmail>
    </Shipment>
    </ShipTransaction>
    </Request>
    This appears to be a bug in the ShipRush 8 for FedEx code. Can anyone else confirm this?

    Randall
    Stokes Web Development
    Last edited by StokesWeb; 12-09-2010 at 05:22 AM. Reason: added additional info
    Reply With Quote

  4. #4
    I have tried changing the comma that was used to separate the multiple email addresses to a semi colon but that did not fix things. It appears that whatever you have entered in the ShipNotificationEmail field is appended to the DeliveryNotificationEmail field.

  5. #5

    Join Date
    Apr 2004
    Posts
    16,778
    SYSOPS is offline
    We have replicated the issue here and have pushed to development for review. Case 25138

    Thank you,
    SYSOPS
    Have Questions? Ask the ShipRush Knowledge Base: https://shiprush.com/kbase
    Reply With Quote

  6. #6

    Join Date
    Apr 2004
    Posts
    16,778
    SYSOPS is offline
    Please go into the settings | shipping settings
    Notification Tab
    Uncheck Auto-copy email from Shipment

    HTH,
    SYSOPS
    Have Questions? Ask the ShipRush Knowledge Base: https://shiprush.com/kbase
    Reply With Quote

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •